What’s Vulnerable › Vulnerabilities
CVE-2026-30935: ImageMagick has a heap Buffer Over-Read in BilateralBlurImage
- Severity: medium (CVSS 4.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-10 · updated 2026-06-17
- Weakness: CWE-125
Description
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to versions 7.1.2-16, BilateralBlurImage contains a heap buffer over-read caused by an incorrect conversion. When processing a crafted image with the -bilateral-blur operation an out of bounds read can occur. This vulnerability is fixed in 7.1.2-16.
Affected products
- ImageMagick: before 7.1.2-16 — fixed in 7.1.2-16
How to fix
Upgrade to a fixed version: ImageMagick 7.1.2-16. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-30935 or the next vulnerability affects your stack