What’s Vulnerable › Vulnerabilities
CVE-2026-30936: ImageMagick has a heap Buffer Overflow in WaveletDenoiseImage
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-10 · updated 2026-06-17
- Weakness: CWE-122
Description
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to versions 7.1.2-16 and 6.9.13-41, a crafted image could cause an out of bounds heap write inside the WaveletDenoiseImage method. When processing a crafted image with the -wavelet-denoise operation an out of bounds write can occur. This vulnerability is fixed in 7.1.2-16 and 6.9.13-41.
Affected products
- ImageMagick: before 6.9.13-41; from 7.0.0-0 before 7.1.2-16 — fixed in 6.9.13-41, 7.1.2-16
How to fix
Upgrade to a fixed version: ImageMagick 6.9.13-41, 7.1.2-16. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-30936 or the next vulnerability affects your stack