What’s Vulnerable › Vulnerabilities
CVE-2026-30946: Parse Server affected by denial-of-service via unbounded query complexity in REST and GraphQL API
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-10 · updated 2026-06-17
- Weakness: CWE-770
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior 9.5.2-alpha.2 and 8.6.15, an unauthenticated attacker can exhaust Parse Server resources (CPU, memory, database connections) through crafted queries that exploit the lack of complexity limits in the REST and GraphQL APIs. All Parse Server deployments using the REST or GraphQL API are affected. This vulnerability is fixed in 9.5.2-alpha.2 and 8.6.15.
Affected products
- parse-community parse-server: before 8.6.15; from 9.0.0 before 9.5.2; 9.5.2-alpha1 — fixed in 8.6.15, 9.5.2
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.15, 9.5.2. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/releases/tag/8.6.15
- https://github.com/parse-community/parse-server/releases/tag/9.5.2-alpha.2
- https://github.com/parse-community/parse-server/security/advisories/GHSA-cmj3-wx7h-ffvg
Get alerted when CVE-2026-30946 or the next vulnerability affects your stack