What’s Vulnerable › Vulnerabilities
CVE-2026-30947: Parse Server ha a bypass of class-level permissions in LiveQuery
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-10 · updated 2026-06-17
- Weakness: CWE-863
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.3 and 8.6.16, class-level permissions (CLP) are not enforced for LiveQuery subscriptions. An unauthenticated or unauthorized client can subscribe to any LiveQuery-enabled class and receive real-time events for all objects, regardless of CLP restrictions. All Parse Server deployments that use LiveQuery with class-level permissions are affected. Data intended to be restricted by CLP is leaked to unauthorized subscribers in real time. This vulnerability is fixed in 9.5.2-alpha.3 and 8.6.16.
Affected products
- parse-community parse-server: before 8.6.16; from 9.0.0 before 9.5.2; 9.5.2-alpha1, 9.5.2-alpha2 — fixed in 8.6.16, 9.5.2
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.16, 9.5.2. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/releases/tag/8.6.16
- https://github.com/parse-community/parse-server/releases/tag/9.5.2-alpha.3
- https://github.com/parse-community/parse-server/security/advisories/GHSA-7ch5-98q2-7289
Get alerted when CVE-2026-30947 or the next vulnerability affects your stack