What’s Vulnerable › Vulnerabilities
CVE-2026-30948: Parse Server has stored cross-site scripting (XSS) via SVG file upload
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-10 · updated 2026-06-17
- Weakness: CWE-79
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.4 and 8.6.17, a stored cross-site scripting (XSS) vulnerability allows any authenticated user to upload an SVG file containing JavaScript. The file is served inline with Content-Type: image/svg+xml and without protective headers, causing the browser to execute embedded scripts in the Parse Server origin. This can be exploited to steal session tokens from localStorage and achieve account takeover. The default fileExtensions option blocks HTML file extensions but does not block SVG, which is a well-known XSS vector. All Parse Server deployments where file upload is enabled for authenticated users (the default) are affected. This vulnerability is fixed in 9.5.2-alpha.4 and 8.6.17.
Affected products
- parse-community parse-server: before 8.6.17; from 9.0.0 before 9.5.2; 9.5.2-alpha1, 9.5.2-alpha2, 9.5.2-alpha3 — fixed in 8.6.17, 9.5.2
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.17, 9.5.2. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/releases/tag/8.6.17
- https://github.com/parse-community/parse-server/releases/tag/9.5.2-alpha.4
- https://github.com/parse-community/parse-server/security/advisories/GHSA-hcj7-6gxh-24ww
Get alerted when CVE-2026-30948 or the next vulnerability affects your stack