What’s Vulnerable › Vulnerabilities
CVE-2026-30962: Parse Server has a protected fields bypass via logical query operators
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-10 · updated 2026-06-17
- Weakness: CWE-284
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.6 and 8.6.19, the validation for protected fields only checks top-level query keys. By wrapping a query constraint on a protected field inside a logical operator, the check is bypassed entirely. This allows any authenticated user to query on protected fields to extract field values. All Parse Server deployments have default protected fields and are vulnerable. This vulnerability is fixed in 9.5.2-alpha.6 and 8.6.19.
Affected products
- parse-community parse-server: before 8.6.19; from 9.0.0 before 9.5.2; 9.5.2-alpha1, 9.5.2-alpha2, 9.5.2-alpha3, 9.5.2-alpha4, 9.5.2-alpha5 — fixed in 8.6.19, 9.5.2
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.19, 9.5.2. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/releases/tag/8.6.19
- https://github.com/parse-community/parse-server/releases/tag/9.5.2-alpha.6
- https://github.com/parse-community/parse-server/security/advisories/GHSA-72hp-qff8-4pvv
Get alerted when CVE-2026-30962 or the next vulnerability affects your stack