What’s Vulnerable › Vulnerabilities
CVE-2026-30964: Webauthn Framework: allowed_origins collapses URL-like origins to host-only values, bypassing exact origin validation
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-10 · updated 2026-06-17
- Weakness: CWE-346
Description
web-auth/webauthn-lib is an open source set of PHP libraries and a Symfony bundle to allow developers to integrate that authentication mechanism into their web applications. Prior to 5.2.4, when allowed_origins is configured, CheckAllowedOrigins reduces URL-like values to their host component and accepts on host match alone. This makes exact origin policies impossible to express: scheme and port differences are silently ignored. This vulnerability is fixed in 5.2.4.
Affected products
- Spomky-Labs Webauthn-Lib: from 5.2.0 before 5.2.4 — fixed in 5.2.4
- Spomky-Labs Webauthn-Symfony-Bundle: from 5.2.0 before 5.2.4 — fixed in 5.2.4
- Spomky-Labs Webauthn Framwork: from 5.2.0 before 5.2.4 — fixed in 5.2.4
How to fix
Upgrade to a fixed version: Spomky-Labs Webauthn-Lib 5.2.4; Spomky-Labs Webauthn-Symfony-Bundle 5.2.4; Spomky-Labs Webauthn Framwork 5.2.4. Check the vendor advisory for mitigations.
References
- https://github.com/web-auth/webauthn-framework/commit/535cc3c2dcbd9c3dfd5e00a254ad4a984e5e7839
- https://github.com/web-auth/webauthn-framework/commit/b4cd9a4394c35fcac6080fd2f84f4f58a30abc01
- https://github.com/web-auth/webauthn-framework/security/advisories/GHSA-f7pm-6hr8-7ggm
- https://github.com/web-auth/webauthn-framework/security/advisories/GHSA-f7pm-6hr8-7ggm
Get alerted when CVE-2026-30964 or the next vulnerability affects your stack