What’s Vulnerable › Vulnerabilities
CVE-2026-30966: Parse Server role escalation and CLP bypass via direct `_Join` table write
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-10 · updated 2026-06-17
- Weakness: CWE-284
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.7 and 8.6.20, Parse Server's internal tables, which store Relation field mappings such as role memberships, can be directly accessed via the REST API or GraphQL API by any client using only the application key. No master key is required. An attacker can create, read, update, or delete records in any internal relationship table. Exploiting this allows the attacker to inject themselves into any Parse Role, gaining all permissions associated with that role, including full read, write, and delete access to classes protected by role-based Class-Level Permissions (CLP). Similarly, writing to any such table that backs a Relation field used in a pointerFields CLP bypasses that access control. This vulnerability is fixed in 9.5.2-alpha.7 and 8.6.20.
Affected products
- parse-community parse-server: before 8.6.20; from 9.0.0 before 9.5.2; 9.5.2-alpha1, 9.5.2-alpha2, 9.5.2-alpha3, 9.5.2-alpha4, 9.5.2-alpha5, 9.5.2-alpha6 — fixed in 8.6.20, 9.5.2
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.20, 9.5.2. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/releases/tag/8.6.20
- https://github.com/parse-community/parse-server/releases/tag/9.5.2-alpha.7
- https://github.com/parse-community/parse-server/security/advisories/GHSA-5f92-jrq3-28rc
Get alerted when CVE-2026-30966 or the next vulnerability affects your stack