What’s Vulnerable › Vulnerabilities

CVE-2026-3108: Terminal Escape Injection in mmctl Report Posts Command

Description

Mattermost versions 11.2.x <= 11.2.2, 10.11.x <= 10.11.10, 11.4.x <= 11.4.0, 11.3.x <= 11.3.1 fail to sanitize user-controlled post content in the mmctl commands terminal output which allows attackers to manipulate administrator terminals via crafted messages containing ANSI and OSC escape sequences that enable screen manipulation, fake prompts, and clipboard hijacking.. Mattermost Advisory ID: MMSA-2026-00599

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.11.11, 11.2.3, 11.3.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-3108 or the next vulnerability affects your stack