What’s Vulnerable › Vulnerabilities
CVE-2026-3125: SSRF vulnerability in opennextjs-cloudflare via /cdn-cgi/ path normalization bypass
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-04 · updated 2026-06-17
- Weakness: CWE-706
Description
A Server-Side Request Forgery (SSRF) vulnerability was identified in the @opennextjs/cloudflare package, resulting from a path normalization bypass in the /cdn-cgi/image/ handler.The @opennextjs/cloudflare worker template includes a /cdn-cgi/image/ handler intended for development use only. In production, Cloudflare's edge intercepts /cdn-cgi/image/ requests before they reach the Worker. However, by substituting a backslash for a forward slash (/cdn-cgi\image/ instead of /cdn-cgi/image/), an attacker can bypass edge interception and have the request reach the Worker directly. The JavaScript URL class then normalizes the backslash to a forward slash, causing the request to match the handler and trigger an unvalidated fetch of arbitrary remote URLs. For example: https://victim-site.com/cdn-cgi\image/aaaa/https://attacker.com In this example, attacker-controlled content from attacker.com is served through the victim site's domain (victim-site.com), violating the same-origin policy and potentially misleading users or other services. Note: This bypass only works via HTTP clients that preserve backslashes in paths (e.g., curl --path-as-is). Browsers normalize backslashes to forward slashes before sending requests. Additionally, Cloudflare Workers with Assets and Cloudflare Pages suffer from a similar vulnerability. Assets stored under /cdn-cgi/ paths are not publicly accessible under normal conditions. However, using the same backslash bypass (/cdn-cgi\... instead of /cdn-cgi/...), these assets become publicly accessible. This could be used to retrieve private data. For example, Open Next projects store incremental cache data under /cdn-cgi/_next_cache, which could be exposed via this bypass.
Affected products
- opennextjs Opennext For Cloudflare: before 1.17.1 — fixed in 1.17.1
How to fix
Upgrade to a fixed version: opennextjs Opennext For Cloudflare 1.17.1. Check the vendor advisory for mitigations.
References
- https://github.com/advisories/GHSA-rvpw-p7vw-wj3m
- https://github.com/opennextjs/opennextjs-cloudflare/pull/1147
- https://www.cve.org/cverecord?id=CVE-2025-6087
- https://www.npmjs.com/package/@opennextjs/cloudflare/v/1.17.1
Get alerted when CVE-2026-3125 or the next vulnerability affects your stack