What’s Vulnerable › Vulnerabilities
CVE-2026-31386
- Severity: high (CVSS 8.6 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-16 · updated 2026-06-17
- Weakness: CWE-78
Description
OpenLiteSpeed and LSWS Enterprise provided by LiteSpeed Technologies contain an OS command injection vulnerability. An arbitrary OS command may be executed by an attacker with the administrative privilege.
Affected products
- LiteSpeed Technologies LiteSpeed Web Server: before 6.3.5 — fixed in 6.3.5
- LiteSpeed Technologies OpenLiteSpeed: through 1.9.0
How to fix
Upgrade to a fixed version: LiteSpeed Technologies LiteSpeed Web Server 6.3.5. Check the vendor advisory for mitigations.
References
- https://jvn.jp/en/jp/JVN22152812/
- https://openlitespeed.org/
- https://www.litespeedtech.com/products/litespeed-web-server
Get alerted when CVE-2026-31386 or the next vulnerability affects your stack