What’s Vulnerable › Vulnerabilities
CVE-2026-31405: media: dvb-net: fix OOB access in ULE extension header tables
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-06 · updated 2026-07-24
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: media: dvb-net: fix OOB access in ULE extension header tables The ule_mandatory_ext_handlers[] and ule_optional_ext_handlers[] tables in handle_one_ule_extension() are declared with 255 elements (valid indices 0-254), but the index htype is derived from network-controlled data as (ule_sndu_type & 0x00FF), giving a range of 0-255. When htype equals 255, an out-of-bounds read occurs on the function pointer table, and the OOB value may be called as a function pointer. Add a bounds check on htype against the array size before either table is accessed. Out-of-range values now cause the SNDU to be discarded.
Affected products
- Linux kernel: from 2.6.12.1 before 5.10.253; from 5.11 before 5.15.203; from 5.16 before 6.1.167; from 6.2 before 6.6.130; from 6.7 before 6.12.78; from 6.13 before 6.18.19 — fixed in 5.10.253, 5.15.203, 6.1.167, 6.12.78, 6.18.19, 6.19.9
How to fix
Upgrade to a fixed version: Linux kernel 5.10.253, 5.15.203, 6.1.167, 6.12.78. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/145e50c2c700fa52b840df7bab206043997dd18e
- https://git.kernel.org/stable/c/1a6da3dbb9985d00743073a1cc1f96e59f5abc30
- https://git.kernel.org/stable/c/24d87712727a5017ad142d63940589a36cd25647
- https://git.kernel.org/stable/c/29ef43ceb121d67b87f4cbb08439e4e9e732eff8
- https://git.kernel.org/stable/c/8bde543d2a5f935ba2a6a6325a2e02f8a9256fbe
- https://git.kernel.org/stable/c/b2bd2ee73b697c177157bba534e1b1064c2e66a0
- https://git.kernel.org/stable/c/e51238718217c4abdb3ccc3b0c0cde265c7ec629
- https://git.kernel.org/stable/c/f2b65dcb78c8990e4c68a906627433be1fe38a92
Get alerted when CVE-2026-31405 or the next vulnerability affects your stack