What’s Vulnerable › Vulnerabilities
CVE-2026-31410: ksmbd: use volume UUID in FS_OBJECT_ID_INFORMATION
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-06 · updated 2026-10-30
Description
In the Linux kernel, the following vulnerability has been resolved: ksmbd: use volume UUID in FS_OBJECT_ID_INFORMATION Use sb->s_uuid for a proper volume identifier as the primary choice. For filesystems that do not provide a UUID, fall back to stfs.f_fsid obtained from vfs_statfs().
Affected products
- Linux kernel: from 5.15 before 6.12.78; from 6.13 before 6.18.20; from 6.19 before 6.19.10; 7.0-rc1, 7.0-rc2, 7.0-rc3, 7.0-rc4 — fixed in 6.12.78, 6.18.20, 6.19.10
- Linux: 5.15 — fixed in 7.0
How to fix
Upgrade to a fixed version: Linux kernel 6.12.78, 6.18.20, 6.19.10; Linux 7.0. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1df0123f96f377282feaae24d8e561fff4a6541f
- https://git.kernel.org/stable/c/3a64125730cabc34fccfbc230c2667c2e14f7308
- https://git.kernel.org/stable/c/3d80ebe6d1b7bc9ad20fd9b0c1a0c56d804f8a0a
- https://git.kernel.org/stable/c/5258e9187703bfd02faf19c37c23ab9d6587f24c
- https://git.kernel.org/stable/c/c283a6ffe6d5d6e5594d991286b9ce15951572e1
- https://git.kernel.org/stable/c/ce00616bc1df675bfdacc968f2bf7c51f4669227
Get alerted when CVE-2026-31410 or the next vulnerability affects your stack