What’s Vulnerable › Vulnerabilities
CVE-2026-31430: X.509: Fix out-of-bounds access when parsing extensions
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-20 · updated 2026-06-17
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: X.509: Fix out-of-bounds access when parsing extensions Leo reports an out-of-bounds access when parsing a certificate with empty Basic Constraints or Key Usage extension because the first byte of the extension is read before checking its length. Fix it. The bug can be triggered by an unprivileged user by submitting a specially crafted certificate to the kernel through the keyrings(7) API. Leo has demonstrated this with a proof-of-concept program responsibly disclosed off-list.
Affected products
- Linux kernel: from 6.4 before 6.6.135; from 6.7 before 6.12.82; from 6.13 before 6.18.23; from 6.19 before 6.19.13; 7.0-rc1, 7.0-rc2, 7.0-rc3, 7.0-rc4, 7.0-rc5, 7.0-rc6 (+1) — fixed in 6.12.82, 6.18.23, 6.19.13, 6.6.135
How to fix
Upgrade to a fixed version: Linux kernel 6.12.82, 6.18.23, 6.19.13, 6.6.135. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/206121294b9cf27f0589857f80d64f87e496ffb2
- https://git.kernel.org/stable/c/30ab358fad0c7daa1d282ec48089901b21b36a20
- https://git.kernel.org/stable/c/672b526def1f94c1be8eb11b885b803da0d8c2f1
- https://git.kernel.org/stable/c/7fb4dadc2734f4020d7543d688b8d49c8e569c61
- https://git.kernel.org/stable/c/d702c3408213bb12bd570bb97204d8340d141c51
Get alerted when CVE-2026-31430 or the next vulnerability affects your stack