What’s Vulnerable › Vulnerabilities
CVE-2026-31432: ksmbd: fix OOB write in QUERY_INFO for compound requests
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-22 · updated 2026-10-30
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: ksmbd: fix OOB write in QUERY_INFO for compound requests When a compound request such as READ + QUERY_INFO(Security) is received, and the first command (READ) consumes most of the response buffer, ksmbd could write beyond the allocated buffer while building a security descriptor. The root cause was that smb2_get_info_sec() checked buffer space using ppntsd_size from xattr, while build_sec_desc() often synthesized a significantly larger descriptor from POSIX ACLs. This patch introduces smb_acl_sec_desc_scratch_len() to accurately compute the final descriptor size beforehand, performs proper buffer checking with smb2_calc_max_out_buf_len(), and uses exact-sized allocation + iov pinning.
Affected products
- Linux kernel: from 5.15.145 before 5.16; from 6.1.71 before 6.2; from 6.6 before 6.12.81; from 6.13 before 6.18.22; from 6.19 before 6.19.12; 7.0-rc1, 7.0-rc2, 7.0-rc3, 7.0-rc4, 7.0-rc5, 7.0-rc6 — fixed in 5.16, 6.2, 6.12.81, 6.18.22, 6.19.12
- Linux: from 6.1.71 before 6.1.191; from 5.15.145 before 5.16 — fixed in 6.1.191, 5.16
How to fix
Upgrade to a fixed version: Linux kernel 5.16, 6.2, 6.12.81, 6.18.22; Linux 6.1.191, 5.16. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/075ea208c648cc2bcd616295b711d3637c61de45
- https://git.kernel.org/stable/c/515c2daab46021221bdf406bef19bc90a44ec617
- https://git.kernel.org/stable/c/533f84264e28c54a79257ea87d2f94a0fcc9a611
- https://git.kernel.org/stable/c/850452af77f55d185f9445e1f7a1db53c5e4aad4
- https://git.kernel.org/stable/c/d48c64fb80ad78b3dd29fb7d79b6ec7bd72bfc09
- https://git.kernel.org/stable/c/fda9522ed6afaec45cabc198d8492270c394c7bc
Get alerted when CVE-2026-31432 or the next vulnerability affects your stack