What’s Vulnerable › Vulnerabilities
CVE-2026-31436: dmaengine: idxd: fix possible wrong descriptor completion in llist_abort_desc()
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-22 · updated 2026-10-19
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: dmaengine: idxd: fix possible wrong descriptor completion in llist_abort_desc() At the end of this function, d is the traversal cursor of flist, but the code completes found instead. This can lead to issues such as NULL pointer dereferences, double completion, or descriptor leaks. Fix this by completing d instead of found in the final list_for_each_entry_safe() loop.
Affected products
- Linux kernel: from 6.8 before 6.12.80; from 6.13 before 6.18.21; from 6.19 before 6.19.11; 7.0-rc1, 7.0-rc2, 7.0-rc3, 7.0-rc4, 7.0-rc5, 7.0-rc6 — fixed in 6.12.80, 6.18.21, 6.19.11
How to fix
Upgrade to a fixed version: Linux kernel 6.12.80, 6.18.21, 6.19.11. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0e4f43779d550e559be13a5cdb763bad92c4cc99
- https://git.kernel.org/stable/c/82656e8daf8de00935ae91b91bed43f4d6e0d644
- https://git.kernel.org/stable/c/e1c9866173c5f8521f2d0768547a01508cb9ff27
- https://git.kernel.org/stable/c/e21da2ad8844585040fe4b82be1ad2fe99d40074
Get alerted when CVE-2026-31436 or the next vulnerability affects your stack