What’s Vulnerable › Vulnerabilities
CVE-2026-31449: ext4: validate p_idx bounds in ext4_ext_correct_indexes
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-22 · updated 2026-10-19
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: ext4: validate p_idx bounds in ext4_ext_correct_indexes ext4_ext_correct_indexes() walks up the extent tree correcting index entries when the first extent in a leaf is modified. Before accessing path[k].p_idx->ei_block, there is no validation that p_idx falls within the valid range of index entries for that level. If the on-disk extent header contains a corrupted or crafted eh_entries value, p_idx can point past the end of the allocated buffer, causing a slab-out-of-bounds read. Fix this by validating path[k].p_idx against EXT_LAST_INDEX() at both access sites: before the while loop and inside it. Return -EFSCORRUPTED if the index pointer is out of range, consistent with how other bounds violations are handled in the ext4 extent tree code.
Affected products
- Linux kernel: from 2.6.19.1 before 6.12.80; from 6.13 before 6.18.21; from 6.19 before 6.19.11; 2.6.19, 2.6.19-rc2, 2.6.19-rc3, 2.6.19-rc4, 2.6.19-rc5, 2.6.19-rc6 (+5) — fixed in 6.12.80, 6.18.21, 6.19.11
How to fix
Upgrade to a fixed version: Linux kernel 6.12.80, 6.18.21, 6.19.11. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/01bf1e0b997d82c0e353b51ed74ef99698043c33
- https://git.kernel.org/stable/c/10242e640b36b91ad03d25f3dc77854bbdff8358
- https://git.kernel.org/stable/c/2acb5c12ebd860f30e4faf67e6cc8c44ddfe5fe8
- https://git.kernel.org/stable/c/39d6e2b67651614bac0dc6592fa9836321910067
- https://git.kernel.org/stable/c/407c944f217c17d4343148011acafebc604d55e1
- https://git.kernel.org/stable/c/4d08401aa13f1531216f1a7ae281ca4806e90a5c
- https://git.kernel.org/stable/c/93f2e975ed658ce09db4d4c2877ca2c06540df83
- https://git.kernel.org/stable/c/c5839b34704c9c2f47f079451bdbb22de0da1ed1
- https://cert-portal.siemens.com/productcert/html/ssa-019113.html
- https://cert-portal.siemens.com/productcert/html/ssa-457936.html
- https://cert-portal.siemens.com/productcert/html/ssa-784472.html
Get alerted when CVE-2026-31449 or the next vulnerability affects your stack