What’s Vulnerable › Vulnerabilities
CVE-2026-31458: mm/damon/sysfs: check contexts->nr before accessing contexts_arr[0]
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-22 · updated 2026-06-17
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: mm/damon/sysfs: check contexts->nr before accessing contexts_arr[0] Multiple sysfs command paths dereference contexts_arr[0] without first verifying that kdamond->contexts->nr == 1. A user can set nr_contexts to 0 via sysfs while DAMON is running, causing NULL pointer dereferences. In more detail, the issue can be triggered by privileged users like below. First, start DAMON and make contexts directory empty (kdamond->contexts->nr == 0). # damo start # cd /sys/kernel/mm/damon/admin/kdamonds/0 # echo 0 > contexts/nr_contexts Then, each of below commands will cause the NULL pointer dereference. # echo update_schemes_stats > state # echo update_schemes_tried_regions > state # echo update_schemes_tried_bytes > state # echo update_schemes_effective_quotas > state # echo update_tuned_intervals > state Guard all commands (except OFF) at the entry point of damon_sysfs_handle_cmd().
Affected products
- Linux kernel: from 5.18 before 6.6.131; from 6.7 before 6.12.80; from 6.13 before 6.18.21; from 6.19 before 6.19.11; 7.0-rc1, 7.0-rc2, 7.0-rc3, 7.0-rc4, 7.0-rc5 — fixed in 6.12.80, 6.18.21, 6.19.11, 6.6.131
How to fix
Upgrade to a fixed version: Linux kernel 6.12.80, 6.18.21, 6.19.11, 6.6.131. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1bfe9fb5ed2667fb075682408b776b5273162615
- https://git.kernel.org/stable/c/1e8da792672481d603fa7cd0d815577220a3ee27
- https://git.kernel.org/stable/c/708033c231bd782858f4ddbb46ee874a5a5fbdab
- https://git.kernel.org/stable/c/aba546061341b56e9ffb37e1eb661a3628b6ec12
- https://git.kernel.org/stable/c/bbe03ad3fb9e714191757ca7b41582f930be7be2
Get alerted when CVE-2026-31458 or the next vulnerability affects your stack