What’s Vulnerable › Vulnerabilities
CVE-2026-31476: ksmbd: do not expire session on binding failure
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-22 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: ksmbd: do not expire session on binding failure When a multichannel session binding request fails (e.g. wrong password), the error path unconditionally sets sess->state = SMB2_SESSION_EXPIRED. However, during binding, sess points to the target session looked up via ksmbd_session_lookup_slowpath() -- which belongs to another connection's user. This allows a remote attacker to invalidate any active session by simply sending a binding request with a wrong password (DoS). Fix this by skipping session expiration when the failed request was a binding attempt, since the session does not belong to the current connection. The reference taken by ksmbd_session_lookup_slowpath() is still correctly released via ksmbd_user_session_put().
Affected products
- Linux kernel: from 5.15.1 before 6.1.168; from 6.2 before 6.6.131; from 6.7 before 6.12.80; from 6.13 before 6.18.21; from 6.19 before 6.19.11; 5.15, 7.0-rc1, 7.0-rc2, 7.0-rc3, 7.0-rc4, 7.0-rc5 (+2) — fixed in 6.1.168, 6.12.80, 6.18.21, 6.19.11, 6.6.131
How to fix
Upgrade to a fixed version: Linux kernel 6.1.168, 6.12.80, 6.18.21, 6.19.11. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1d1888b4a7aec518b707f6eca0bf08992c0e8da3
- https://git.kernel.org/stable/c/4642ea35c03cf3d3558c009df4757cdb7af3f82d
- https://git.kernel.org/stable/c/6fafc4c4238e538969f1375f9ecdc6587c53f1cc
- https://git.kernel.org/stable/c/9bbb19d21ded7d78645506f20d8c44895e3d0fb9
- https://git.kernel.org/stable/c/a897064a457056acb976e20e3007cdf553de340f
- https://git.kernel.org/stable/c/e0e5edc81b241c70355217de7e120c97c3429deb
- https://git.kernel.org/stable/c/f5300690c23c5ac860499bb37dbc09cf43fd62e6
Get alerted when CVE-2026-31476 or the next vulnerability affects your stack