What’s Vulnerable › Vulnerabilities
CVE-2026-31523: nvme-pci: ensure we're polling a polled queue
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-22 · updated 2026-06-17
- Weakness: CWE-367
Description
In the Linux kernel, the following vulnerability has been resolved: nvme-pci: ensure we're polling a polled queue A user can change the polled queue count at run time. There's a brief window during a reset where a hipri task may try to poll that queue before the block layer has updated the queue maps, which would race with the now interrupt driven queue and may cause double completions.
Affected products
- Linux kernel: from 5.0 before 5.10.253; from 5.11 before 5.15.203; from 5.16 before 6.1.168; from 6.2 before 6.6.131; from 6.7 before 6.12.80; from 6.13 before 6.18.21 — fixed in 5.10.253, 5.15.203, 6.1.168, 6.12.80, 6.18.21, 6.19.11
How to fix
Upgrade to a fixed version: Linux kernel 5.10.253, 5.15.203, 6.1.168, 6.12.80. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0685dd9cb855ab77fcf3577b4702ba1d6df1c98d
- https://git.kernel.org/stable/c/166e31d7dbf6aa44829b98aa446bda5c9580f12a
- https://git.kernel.org/stable/c/6f12734c4b619f923a4df0b1a46b8098b187d324
- https://git.kernel.org/stable/c/965e2c943f065122f14282a88d70a8a92e12a4da
- https://git.kernel.org/stable/c/acbc72dd1a09df53cafcf577259f4678be6afd6d
- https://git.kernel.org/stable/c/b222680ba55e018426c4535067a008f1d81a5d21
- https://git.kernel.org/stable/c/b96c7b25eb1b748f3e3b1832ebf028b0b223d7e3
- https://git.kernel.org/stable/c/ba167d5982e2eb6ff9356d409eca592ce99555da
Get alerted when CVE-2026-31523 or the next vulnerability affects your stack