What’s Vulnerable › Vulnerabilities
CVE-2026-31554: futex: Require sys_futex_requeue() to have identical flags
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-24 · updated 2026-10-19
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: futex: Require sys_futex_requeue() to have identical flags Nicholas reported that his LLM found it was possible to create a UaF when sys_futex_requeue() is used with different flags. The initial motivation for allowing different flags was the variable sized futex, but since that hasn't been merged (yet), simply mandate the flags are identical, as is the case for the old style sys_futex() requeue operations.
Affected products
- Linux kernel: from 6.7.1 before 6.12.80; from 6.13 before 6.18.21; from 6.19 before 6.19.11; 6.7, 7.0-rc1, 7.0-rc2, 7.0-rc3, 7.0-rc4, 7.0-rc5 (+2) — fixed in 6.12.80, 6.18.21, 6.19.11
How to fix
Upgrade to a fixed version: Linux kernel 6.12.80, 6.18.21, 6.19.11. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/027145ace09fad4c7cbcd6c61fe9b429c63eb0e5
- https://git.kernel.org/stable/c/18b7d09c2b794c71d4252f3ea2cf84ad12b73d6a
- https://git.kernel.org/stable/c/19f94b39058681dec64a10ebeb6f23fe7fc3f77a
- https://git.kernel.org/stable/c/e2f78c7ec1655fedd945366151ba54fcb9580508
Get alerted when CVE-2026-31554 or the next vulnerability affects your stack