What’s Vulnerable › Vulnerabilities

CVE-2026-3160: Unintended Proxy or Intermediary ('Confused Deputy') in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 13.7 before 18.9.7, 18.10 before 18.10.6, and 18.11 before 18.11.3 that could have allowed an authenticated user to view Jira issues outside the configured project scope due to an integration filter functioning only as a display control rather than enforcing access boundaries as specified.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.10.6, 18.11.3, 18.9.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-3160 or the next vulnerability affects your stack