What’s Vulnerable › Vulnerabilities
CVE-2026-31619: ALSA: fireworks: bound device-supplied status before string array lookup
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-24 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: ALSA: fireworks: bound device-supplied status before string array lookup The status field in an EFW response is a 32-bit value supplied by the firewire device. efr_status_names[] has 17 entries so a status value outside that range goes off into the weeds when looking at the %s value. Even worse, the status could return EFR_STATUS_INCOMPLETE which is 0x80000000, and is obviously not in that array of potential strings. Fix this up by properly bounding the index against the array size and printing "unknown" if it's not recognized.
Affected products
- Linux kernel: from 3.16 before 6.6.136; from 6.7 before 6.12.83; from 6.13 before 6.18.24; from 6.19 before 6.19.14; from 7.0 before 7.0.1 — fixed in 6.12.83, 6.18.24, 6.19.14, 6.6.136, 7.0.1
How to fix
Upgrade to a fixed version: Linux kernel 6.12.83, 6.18.24, 6.19.14, 6.6.136. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/07704bbf36f57e4379e4cadf96410dab14621e3b
- https://git.kernel.org/stable/c/183aa0de0f680496b9feb85c9d182681ad4600dd
- https://git.kernel.org/stable/c/327f8e730e3c65ec97df9d3b07de66aeb3dc932d
- https://git.kernel.org/stable/c/62fcb273fbee5b2a0e7ed41cc914c8d7d1a5d285
- https://git.kernel.org/stable/c/67cfd14074cdafab5de3f7cfc0952c1a9b653e5d
- https://git.kernel.org/stable/c/682d8accf0d83a871e8c327b95c81f53902c922b
- https://git.kernel.org/stable/c/cc624b3d2be13297100539b64ad950695188e046
- https://git.kernel.org/stable/c/e103f98f6615ed2934e9cf340654f0cad9eb8a8a
- https://git.kernel.org/stable/c/f856f4b6efd51be7950e4b84c06cd961961ca41c
Get alerted when CVE-2026-31619 or the next vulnerability affects your stack