What’s Vulnerable › Vulnerabilities
CVE-2026-31631: rxrpc: Fix buffer overread in rxgk_do_verify_authenticator()
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-24 · updated 2026-10-19
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: rxrpc: Fix buffer overread in rxgk_do_verify_authenticator() Fix rxgk_do_verify_authenticator() to check the buffer size before checking the nonce.
Affected products
- Linux kernel: from 6.16.1 before 6.18.23; from 6.19 before 6.19.13; 6.16, 7.0-rc1, 7.0-rc2, 7.0-rc3, 7.0-rc4, 7.0-rc5 (+2) — fixed in 6.18.23, 6.19.13
How to fix
Upgrade to a fixed version: Linux kernel 6.18.23, 6.19.13. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1c4422d8be81718ecb15d79aedff607323085201
- https://git.kernel.org/stable/c/794586789800b16dcbe235452494f4223ac80413
- https://git.kernel.org/stable/c/f564af387c8c28238f8ebc13314c589d7ba8475d
Get alerted when CVE-2026-31631 or the next vulnerability affects your stack