What’s Vulnerable › Vulnerabilities
CVE-2026-31633: rxrpc: Fix integer overflow in rxgk_verify_response()
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-24 · updated 2026-10-19
- Weakness: CWE-190
Description
In the Linux kernel, the following vulnerability has been resolved: rxrpc: Fix integer overflow in rxgk_verify_response() In rxgk_verify_response(), there's a potential integer overflow due to rounding up token_len before checking it, thereby allowing the length check to be bypassed. Fix this by checking the unrounded value against len too (len is limited as the response must fit in a single UDP packet).
Affected products
- Linux kernel: from 6.16.1 before 6.18.23; from 6.19 before 6.19.13; 6.16, 7.0-rc1, 7.0-rc2, 7.0-rc3, 7.0-rc4, 7.0-rc5 (+2) — fixed in 6.18.23, 6.19.13
How to fix
Upgrade to a fixed version: Linux kernel 6.18.23, 6.19.13. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1f864d9daaf622aeaa774404fd51e7d6a435b046
- https://git.kernel.org/stable/c/699e52180f4231c257821c037ed5c99d5eb0edb8
- https://git.kernel.org/stable/c/c1e242beb6b1efc3c286f617e8d940c8fbf2ed41
Get alerted when CVE-2026-31633 or the next vulnerability affects your stack