What’s Vulnerable › Vulnerabilities
CVE-2026-31658: net: altera-tse: fix skb leak on DMA mapping error in tse_start_xmit()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-24 · updated 2026-10-15
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: net: altera-tse: fix skb leak on DMA mapping error in tse_start_xmit() When dma_map_single() fails in tse_start_xmit(), the function returns NETDEV_TX_OK without freeing the skb. Since NETDEV_TX_OK tells the stack the packet was consumed, the skb is never freed, leaking memory on every DMA mapping failure. Add dev_kfree_skb_any() before returning to properly free the skb.
Affected products
- Linux kernel: from 3.15.1 before 5.10.253; from 5.11 before 5.15.203; from 5.16 before 6.1.169; from 6.2 before 6.6.135; from 6.7 before 6.12.82; from 6.13 before 6.18.23 — fixed in 5.10.253, 5.15.203, 6.1.169, 6.12.82, 6.18.23, 6.19.13
How to fix
Upgrade to a fixed version: Linux kernel 5.10.253, 5.15.203, 6.1.169, 6.12.82. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/2eb9d67704ca8f1101f7435b85f113ede471f9f2
- https://git.kernel.org/stable/c/3aca300e88afe56afb000cdc4c65383014fb17f9
- https://git.kernel.org/stable/c/60f462cd2716d86bd2174f9d5e035c9278f30480
- https://git.kernel.org/stable/c/6dede3967619b5944003227a5d09fdc21ed57d10
- https://git.kernel.org/stable/c/9f3ec44aeb58501d11834048d5d0dbaeacb6d4e7
- https://git.kernel.org/stable/c/ae2cd46f57f422b51aedd406ff5d75cbff401d5d
- https://git.kernel.org/stable/c/cb1d318702fdf643061350d164250198df4116f2
- https://git.kernel.org/stable/c/d5ec406f0543bd6cdfd563b08015fdec8c4d5712
- https://cert-portal.siemens.com/productcert/html/ssa-019113.html
- https://cert-portal.siemens.com/productcert/html/ssa-082556.html
- https://cert-portal.siemens.com/productcert/html/ssa-457936.html
Get alerted when CVE-2026-31658 or the next vulnerability affects your stack