What’s Vulnerable › Vulnerabilities
CVE-2026-31675: net/sched: sch_netem: fix out-of-bounds access in packet corruption
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-25 · updated 2026-10-30
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: net/sched: sch_netem: fix out-of-bounds access in packet corruption In netem_enqueue(), the packet corruption logic uses get_random_u32_below(skb_headlen(skb)) to select an index for modifying skb->data. When an AF_PACKET TX_RING sends fully non-linear packets over an IPIP tunnel, skb_headlen(skb) evaluates to 0. Passing 0 to get_random_u32_below() takes the variable-ceil slow path which returns an unconstrained 32-bit random integer. Using this unconstrained value as an offset into skb->data results in an out-of-bounds memory access. Fix this by verifying skb_headlen(skb) is non-zero before attempting to corrupt the linear data area. Fully non-linear packets will silently bypass the corruption logic.
Affected products
- Linux kernel: from 2.6.16 before 6.6.134; from 6.7 before 6.12.81; from 6.13 before 6.18.22; from 6.19 before 6.19.12; 7.0-rc1, 7.0-rc2, 7.0-rc3, 7.0-rc4, 7.0-rc5, 7.0-rc6 — fixed in 6.6.134, 6.12.81, 6.18.22, 6.19.12
- Linux: 2.6.16 — fixed in 7.0
How to fix
Upgrade to a fixed version: Linux kernel 6.6.134, 6.12.81, 6.18.22, 6.19.12; Linux 7.0. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/13a66ca1e235d4bcd53d12d4c68490cad7f8e46f
- https://git.kernel.org/stable/c/3a2999704ac36cfb4041fed3652d26a3373e8d12
- https://git.kernel.org/stable/c/4fd258e281fa8bc15e9ce2c7691941537e9258ad
- https://git.kernel.org/stable/c/8d3de49c22ec0ec8f7199cc7e2b0559de7306f87
- https://git.kernel.org/stable/c/a14b56863348686dd0387eea8ce66b85cf455908
- https://git.kernel.org/stable/c/d64cb81dcbd54927515a7f65e5e24affdc73c14b
Get alerted when CVE-2026-31675 or the next vulnerability affects your stack