What’s Vulnerable › Vulnerabilities
CVE-2026-3172: pgvector buffer overflow in parallel HNSW index build
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-25 · updated 2026-06-17
- Weakness: CWE-191
Description
Buffer overflow in parallel HNSW index build in pgvector 0.6.0 through 0.8.1 allows a database user to leak sensitive data from other relations or crash the database server.
Affected products
- pgvector: from 0.8.0 before 0.8.2; 0.7.0, 0.6.0 — fixed in 0.8.2
How to fix
Upgrade to a fixed version: pgvector 0.8.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-3172 or the next vulnerability affects your stack