What’s Vulnerable › Vulnerabilities
CVE-2026-31720: usb: gadget: f_uac1_legacy: validate control request size
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-01 · updated 2026-06-17
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: usb: gadget: f_uac1_legacy: validate control request size f_audio_complete() copies req->length bytes into a 4-byte stack variable: u32 data = 0; memcpy(&data, req->buf, req->length); req->length is derived from the host-controlled USB request path, which can lead to a stack out-of-bounds write. Validate req->actual against the expected payload size for the supported control selectors and decode only the expected amount of data. This avoids copying a host-influenced length into a fixed-size stack object.
Affected products
- Linux kernel: from 2.6.31 before 5.10.253; from 5.11 before 5.15.203; from 5.16 before 6.1.168; from 6.2 before 6.6.134; from 6.7 before 6.12.81; from 6.13 before 6.18.22 — fixed in 5.10.253, 5.15.203, 6.1.168, 6.12.81, 6.18.22, 6.19.12
How to fix
Upgrade to a fixed version: Linux kernel 5.10.253, 5.15.203, 6.1.168, 6.12.81. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0d41772d98dcaf6c17e875b7d0ea0154ae1191ee
- https://git.kernel.org/stable/c/21b11e8581285c6f10ef43d05df349d445f24273
- https://git.kernel.org/stable/c/26304d124e7f0383f8fe1168b5801a0ac7e16b1c
- https://git.kernel.org/stable/c/557d1d4e862eccd0b74cc377b66de3e1e8d49605
- https://git.kernel.org/stable/c/6e0e34d85cd46ceb37d16054e97a373a32770f6c
- https://git.kernel.org/stable/c/8e5eb1d6e6a3d7bbea9c92132d0cda5793176426
- https://git.kernel.org/stable/c/be2d32f0c3fe333d14c0a9ca90328dacbc3e06b8
- https://git.kernel.org/stable/c/c6da4fed7537aec19880c24f6c3a95065adb1406
Get alerted when CVE-2026-31720 or the next vulnerability affects your stack