What’s Vulnerable › Vulnerabilities
CVE-2026-31738: vxlan: validate ND option lengths in vxlan_na_create
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-01 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: vxlan: validate ND option lengths in vxlan_na_create vxlan_na_create() walks ND options according to option-provided lengths. A malformed option can make the parser advance beyond the computed option span or use a too-short source LLADDR option payload. Validate option lengths against the remaining NS option area before advancing, and only read source LLADDR when the option is large enough for an Ethernet address.
Affected products
- Linux kernel: from 3.12.18 before 3.13; from 3.13.10 before 3.14; from 3.14.1 before 5.10.253; from 5.11 before 5.15.203; from 5.16 before 6.1.168; from 6.2 before 6.6.134 — fixed in 3.13, 3.14, 5.10.253, 5.15.203, 6.1.168, 6.12.81
How to fix
Upgrade to a fixed version: Linux kernel 3.13, 3.14, 5.10.253, 5.15.203. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/2029712fb2c87e9a8c75094906f2ee29bf08c500
- https://git.kernel.org/stable/c/602596c69a70e50d9ab8c6ae0290a01f88229dd7
- https://git.kernel.org/stable/c/901c1dd3bab2955d7e664f914c374c8c3ac2b958
- https://git.kernel.org/stable/c/afa9a05e6c4971bd5586f1b304e14d61fb3d9385
- https://git.kernel.org/stable/c/b69c4236255bd8de16cd876e58c6f0867d1d78b1
- https://git.kernel.org/stable/c/de20d2e3b9179d132f5f5b44e490d7c916c6321b
- https://git.kernel.org/stable/c/e476745917a1e288eb15e7ff49d286a86a4861d3
- https://git.kernel.org/stable/c/eddfce70a6f3107d1679b0c2fcbeb96b593bd679
Get alerted when CVE-2026-31738 or the next vulnerability affects your stack