What’s Vulnerable › Vulnerabilities
CVE-2026-31743: nvmem: zynqmp_nvmem: Fix buffer size in DMA and memcpy
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-01 · updated 2026-06-17
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: nvmem: zynqmp_nvmem: Fix buffer size in DMA and memcpy Buffer size used in dma allocation and memcpy is wrong. It can lead to undersized DMA buffer access and possible memory corruption. use correct buffer size in dma_alloc_coherent and memcpy.
Affected products
- Linux kernel: from 6.9 before 6.12.81; from 6.13 before 6.18.22; from 6.19 before 6.19.12; 7.0-rc1, 7.0-rc2, 7.0-rc3, 7.0-rc4, 7.0-rc5, 7.0-rc6 — fixed in 6.12.81, 6.18.22, 6.19.12
How to fix
Upgrade to a fixed version: Linux kernel 6.12.81, 6.18.22, 6.19.12. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/2f6e5b9964d0a63a5ba84fca2642876afb70a662
- https://git.kernel.org/stable/c/6c01e7f11f5e5f22285d19510a9643e2506e13c3
- https://git.kernel.org/stable/c/784ed4abded1ca4b525fa4cade8b02f8c5d2a087
- https://git.kernel.org/stable/c/f9b88613ff402aa6fe8fd020573cb95867ae947e
Get alerted when CVE-2026-31743 or the next vulnerability affects your stack