What’s Vulnerable › Vulnerabilities
CVE-2026-31748: comedi: me_daq: Fix potential overrun of firmware buffer
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-01 · updated 2026-06-17
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: comedi: me_daq: Fix potential overrun of firmware buffer `me2600_xilinx_download()` loads the firmware that was requested by `request_firmware()`. It is possible for it to overrun the source buffer because it blindly trusts the file format. It reads a data stream length from the first 4 bytes into variable `file_length` and reads the data stream contents of length `file_length` from offset 16 onwards. Although it checks that the supplied firmware is at least 16 bytes long, it does not check that it is long enough to contain the data stream. Add a test to ensure that the supplied firmware is long enough to contain the header and the data stream. On failure, log an error and return `-EINVAL`.
Affected products
- Linux kernel: from 2.6.29 before 5.10.253; from 5.11 before 5.15.203; from 5.16 before 6.1.168; from 6.2 before 6.6.134; from 6.7 before 6.12.81; from 6.13 before 6.18.22 — fixed in 5.10.253, 5.15.203, 6.1.168, 6.12.81, 6.18.22, 6.19.12
How to fix
Upgrade to a fixed version: Linux kernel 5.10.253, 5.15.203, 6.1.168, 6.12.81. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1bf8761eb59e94bf7b8c17b2a1ee48f14378b172
- https://git.kernel.org/stable/c/2fc25a4c2e055cd42ea39a1b42c89bfef70e0319
- https://git.kernel.org/stable/c/9f39fa07259eb342908e4aa0271dee038a8ce4f8
- https://git.kernel.org/stable/c/a47ae40339c1048f519df33ff8840731720f57cb
- https://git.kernel.org/stable/c/c16ac4e173a05011437a2d868f70cc415339065a
- https://git.kernel.org/stable/c/c8c607a77aab783f2e38cc2e0f24aa6c8f6d200b
- https://git.kernel.org/stable/c/cc797d4821c754c701d9714b58bea947e31dbbe0
- https://git.kernel.org/stable/c/f3f8ec00cfb8d8e826e30b1138a56355b88e9ba8
Get alerted when CVE-2026-31748 or the next vulnerability affects your stack