What’s Vulnerable › Vulnerabilities
CVE-2026-31752: bridge: br_nd_send: validate ND option lengths
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-01 · updated 2026-10-15
Description
In the Linux kernel, the following vulnerability has been resolved: bridge: br_nd_send: validate ND option lengths br_nd_send() walks ND options according to option-provided lengths. A malformed option can make the parser advance beyond the computed option span or use a too-short source LLADDR option payload. Validate option lengths against the remaining NS option area before advancing, and only read source LLADDR when the option is large enough for an Ethernet address.
Affected products
- Linux kernel: from 4.15 before 5.10.253; from 5.11 before 5.15.203; from 5.16 before 6.1.168; from 6.2 before 6.6.134; from 6.7 before 6.12.81; from 6.13 before 6.18.22 — fixed in 5.10.253, 5.15.203, 6.1.168, 6.12.81, 6.18.22, 6.19.12
How to fix
Upgrade to a fixed version: Linux kernel 5.10.253, 5.15.203, 6.1.168, 6.12.81. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/259466f76f5a2148aff11134e68f4b4c6d52725b
- https://git.kernel.org/stable/c/82a42eceec7c6bdb0e0da94c0542a173b7ea57f2
- https://git.kernel.org/stable/c/837392a38445729c22e03d3abcf33f07763efd85
- https://git.kernel.org/stable/c/850837965af15707fd3142c1cf3c5bfaf022299b
- https://git.kernel.org/stable/c/c49b9256bbacb6a135654aebd12e4c0e87166b7c
- https://git.kernel.org/stable/c/e0bfd6d4dc77ab345b6c65eef0cfe9b2f69085aa
- https://git.kernel.org/stable/c/e71303a9190496136e240c4f2872b7b0b16027a7
- https://git.kernel.org/stable/c/ee02d8991fd7bd86ed6ebd0deb4aab53feb0e43a
- https://cert-portal.siemens.com/productcert/html/ssa-019113.html
- https://cert-portal.siemens.com/productcert/html/ssa-082556.html
- https://cert-portal.siemens.com/productcert/html/ssa-457936.html
Get alerted when CVE-2026-31752 or the next vulnerability affects your stack