What’s Vulnerable › Vulnerabilities
CVE-2026-31768: iio: adc: ti-adc161s626: use DMA-safe memory for spi_read()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-01 · updated 2026-10-15
Description
In the Linux kernel, the following vulnerability has been resolved: iio: adc: ti-adc161s626: use DMA-safe memory for spi_read() Add a DMA-safe buffer and use it for spi_read() instead of a stack memory. All SPI buffers must be DMA-safe. Since we only need up to 3 bytes, we just use a u8[] instead of __be16 and __be32 and change the conversion functions appropriately.
Affected products
- Linux kernel: from 4.9 before 6.1.168; from 6.2 before 6.6.134; from 6.7 before 6.12.81; from 6.13 before 6.18.22; from 6.19 before 6.19.12; 7.0-rc1, 7.0-rc2, 7.0-rc3, 7.0-rc4, 7.0-rc5, 7.0-rc6 — fixed in 6.1.168, 6.12.81, 6.18.22, 6.19.12, 6.6.134
How to fix
Upgrade to a fixed version: Linux kernel 6.1.168, 6.12.81, 6.18.22, 6.19.12. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/014c6d27878d3883f7bb065610768fd021de1a96
- https://git.kernel.org/stable/c/67b3a91bdc48220bfb67155ab528121b9c822782
- https://git.kernel.org/stable/c/768461517a28d80fe81ea4d5d03a90cd184ea6ad
- https://git.kernel.org/stable/c/b3bb8faeca1a2ef7be95ee8a512b639f9ffce947
- https://git.kernel.org/stable/c/d2d031b0786ea66ab0577c9d2d71435068d32199
- https://git.kernel.org/stable/c/fa64aab25aba47296aa8d12bb4c88ec3fecb2054
- https://cert-portal.siemens.com/productcert/html/ssa-019113.html
- https://cert-portal.siemens.com/productcert/html/ssa-082556.html
- https://cert-portal.siemens.com/productcert/html/ssa-457936.html
Get alerted when CVE-2026-31768 or the next vulnerability affects your stack