What’s Vulnerable › Vulnerabilities
CVE-2026-31798: JumpServer Improper Certificate Validation in Custom SMS API Client
- Severity: medium (CVSS 5.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-13 · updated 2026-06-17
- Weakness: CWE-295
Description
JumpServer is an open source bastion host and an operation and maintenance security audit system. Prior to v4.10.16-lts, JumpServer improperly validates certificates in the Custom SMS API Client. When JumpServer sends MFA/OTP codes via Custom SMS API, an attacker can intercept the request and capture the verification code BEFORE it reaches the user's phone. This vulnerability is fixed in v4.10.16-lts.
Affected products
- jumpserver: before 4.10.16 — fixed in 4.10.16
How to fix
Upgrade to a fixed version: jumpserver 4.10.16. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-31798 or the next vulnerability affects your stack