What’s Vulnerable › Vulnerabilities
CVE-2026-31800: Parse Server: Classes `_GraphQLConfig` and `_Audience` master key bypass via generic class routes
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-10 · updated 2026-06-17
- Weakness: CWE-862
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.12 and 8.6.25, the _GraphQLConfig and _Audience internal classes can be read, modified, and deleted via the generic /classes/_GraphQLConfig and /classes/_Audience REST API routes without master key authentication. This bypasses the master key enforcement that exists on the dedicated /graphql-config and /push_audiences endpoints. An attacker can read, modify and delete GraphQL configuration and push audience data. This vulnerability is fixed in 9.5.2-alpha.12 and 8.6.25.
Affected products
- parse-community parse-server: before 8.6.25; from 9.0.0 before 9.5.2; 9.5.2-alpha1, 9.5.2-alpha10, 9.5.2-alpha11, 9.5.2-alpha2, 9.5.2-alpha3, 9.5.2-alpha4 (+5) — fixed in 8.6.25, 9.5.2
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.25, 9.5.2. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/releases/tag/8.6.25
- https://github.com/parse-community/parse-server/releases/tag/9.5.2-alpha.12
- https://github.com/parse-community/parse-server/security/advisories/GHSA-7xg7-rqf6-pw6c
Get alerted when CVE-2026-31800 or the next vulnerability affects your stack