What’s Vulnerable › Vulnerabilities
CVE-2026-31814: Yamux remote Panic via malformed WindowUpdate credit
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-13 · updated 2026-06-17
- Weakness: CWE-190
Description
Yamux is a stream multiplexer over reliable, ordered connections such as TCP/IP. From 0.13.0 to before 0.13.9, a specially crafted WindowUpdate can cause arithmetic overflow in send-window accounting, which triggers a panic in the connection state machine. This is remotely reachable over a normal network connection and does not require authentication. This vulnerability is fixed in 0.13.9.
Affected products
- libp2p rust-yamux: from 0.13.0 before 0.13.9 — fixed in 0.13.9
How to fix
Upgrade to a fixed version: libp2p rust-yamux 0.13.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-31814 or the next vulnerability affects your stack