What’s Vulnerable › Vulnerabilities
CVE-2026-31818: Budibase: Server-Side Request Forgery via REST Connector with Empty Default Blacklist
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-03 · updated 2026-10-06
- Weakness: CWE-918
Description
Budibase is an open-source low-code platform. Prior to version 3.33.4, a server-side request forgery (SSRF) vulnerability exists in Budibase's REST datasource connector. The platform's SSRF protection mechanism (IP blacklist) is rendered completely ineffective because the BLACKLIST_IPS environment variable is not set by default in any of the official deployment configurations. When this variable is empty, the blacklist function unconditionally returns false, allowing all requests through without restriction. This issue has been patched in version 3.33.4.
Affected products
- budibase: before 3.33.4 — fixed in 3.33.4
How to fix
Upgrade to a fixed version: budibase 3.33.4. Check the vendor advisory for mitigations.
References
- https://github.com/Budibase/budibase/commit/5b0fe83d4ece52696b62589cba89ef50cc009732
- https://github.com/Budibase/budibase/pull/18236
- https://github.com/Budibase/budibase/releases/tag/3.33.4
- https://github.com/Budibase/budibase/security/advisories/GHSA-7r9j-r86q-7g45
Get alerted when CVE-2026-31818 or the next vulnerability affects your stack