What’s Vulnerable › Vulnerabilities
CVE-2026-31828: Parse Server has an LDAP injection via unsanitized user input in DN and group filter construction
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-10 · updated 2026-06-17
- Weakness: CWE-90
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.13 and 8.6.26, the LDAP authentication adapter is vulnerable to LDAP injection. User-supplied input (authData.id) is interpolated directly into LDAP Distinguished Names (DN) and group search filters without escaping special characters. This allows an attacker with valid LDAP credentials to manipulate the bind DN structure and to bypass group membership checks. This enables privilege escalation from any authenticated LDAP user to a member of any restricted group. The vulnerability affects Parse Server deployments that use the LDAP authentication adapter with group-based access control. This vulnerability is fixed in 9.5.2-alpha.13 and 8.6.26.
Affected products
- parse-community parse-server: before 8.6.26; from 9.0.0 before 9.5.2; 9.5.2-alpha1, 9.5.2-alpha10, 9.5.2-alpha11, 9.5.2-alpha12, 9.5.2-alpha2, 9.5.2-alpha3 (+6) — fixed in 8.6.26, 9.5.2
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.26, 9.5.2. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/releases/tag/8.6.26
- https://github.com/parse-community/parse-server/releases/tag/9.5.2-alpha.13
- https://github.com/parse-community/parse-server/security/advisories/GHSA-7m6r-fhh7-r47c
Get alerted when CVE-2026-31828 or the next vulnerability affects your stack