What’s Vulnerable › Vulnerabilities
CVE-2026-31829: Flowise affected by Server-Side Request Forgery (SSRF) in HTTP Node Leading to Internal Network Access
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-10 · updated 2026-06-17
- Weakness: CWE-918
Description
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.0.13, Flowise exposes an HTTP Node in AgentFlow and Chatflow that performs server-side HTTP requests using user-controlled URLs. By default, there are no restrictions on target hosts, including private/internal IP ranges (RFC 1918), localhost, or cloud metadata endpoints. This enables Server-Side Request Forgery (SSRF), allowing any user interacting with a publicly exposed chatflow to force the Flowise server to make requests to internal network resources that are inaccessible from the public internet. This vulnerability is fixed in 3.0.13.
Affected products
- FlowiseAI Flowise: before 3.0.13 — fixed in 3.0.13
How to fix
Upgrade to a fixed version: FlowiseAI Flowise 3.0.13. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-31829 or the next vulnerability affects your stack