What’s Vulnerable › Vulnerabilities
CVE-2026-31834: Umbraco Affected by Vertical Privilege Escalation via Missing Authorization Checks
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-10 · updated 2026-06-17
- Weakness: CWE-269
Description
Umbraco is an ASP.NET CMS. From 15.3.1 to before 16.5.1 and 17.2.2, A privilege escalation vulnerability has been identified in Umbraco CMS. Under certain conditions, authenticated backoffice users with permission to manage users, may be able to elevate their privileges due to insufficient authorization enforcement when modifying user group memberships. The affected functionality does not properly validate whether a user has sufficient privileges to assign highly privileged roles. This vulnerability is fixed in 16.5.1 and 17.2.2.
Affected products
- Umbraco-CMS: from 15.3.1 before 16.5.1; from 17.0.0 before 17.2.2 — fixed in 16.5.1, 17.2.2
How to fix
Upgrade to a fixed version: Umbraco-CMS 16.5.1, 17.2.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-31834 or the next vulnerability affects your stack