What’s Vulnerable › Vulnerabilities
CVE-2026-31840: Parse Server has a SQL injection via dot-notation field name in PostgreSQL
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-11 · updated 2026-06-17
- Weakness: CWE-89
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.2 and 8.6.28, an attacker can use a dot-notation field name in combination with the sort query parameter to inject SQL into the PostgreSQL database through an improper escaping of sub-field values in dot-notation queries. The vulnerability may also affect queries that use dot-notation field names with the distinct and where query parameters. This vulnerability only affects deployments using a PostgreSQL database. This vulnerability is fixed in 9.6.0-alpha.2 and 8.6.28.
Affected products
- parse-community parse-server: before 8.6.28; from 9.0.0 before 9.6.0; 9.6.0-alpha1 — fixed in 8.6.28, 9.6.0
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.28, 9.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/releases/tag/8.6.28
- https://github.com/parse-community/parse-server/releases/tag/9.6.0-alpha.2
- https://github.com/parse-community/parse-server/security/advisories/GHSA-qpr4-jrj4-6f27
Get alerted when CVE-2026-31840 or the next vulnerability affects your stack