What’s Vulnerable › Vulnerabilities
CVE-2026-31841: Raw exposure of database statements in Hyperterse MCP search tool
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-12 · updated 2026-06-17
- Weakness: CWE-433
Description
Hyperterse is a tool-first MCP framework for building AI-ready backend surfaces from declarative config. Prior to v2.2.0, the search tool allows LLMs to search for tools using natural language. While returning results, Hyperterse also returned the raw SQL queries, exposing statements which were supposed to be executed under the hood, and protected from being displayed publicly. This issue has been fixed as of v2.2.0.
Affected products
- hyperterse: before 2.2.0 — fixed in 2.2.0
How to fix
Upgrade to a fixed version: hyperterse 2.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/hyperterse/hyperterse/releases/tag/v2.2.0
- https://github.com/hyperterse/hyperterse/security/advisories/GHSA-92gp-jfgx-9qpv
Get alerted when CVE-2026-31841 or the next vulnerability affects your stack