What’s Vulnerable › Vulnerabilities
CVE-2026-31856: Parse Server has a SQL injection via `Increment` operation on nested object field in PostgreSQL
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-11 · updated 2026-06-17
- Weakness: CWE-89
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. A SQL injection vulnerability exists in the PostgreSQL storage adapter when processing Increment operations on nested object fields using dot notation (e.g., stats.counter). The amount value is interpolated directly into the SQL query without parameterization or type validation. An attacker who can send write requests to the Parse Server REST API can inject arbitrary SQL subqueries to read any data from the database, bypassing CLPs and ACLs. MongoDB deployments are not affected. This vulnerability is fixed in 9.6.0-alpha.3 and 8.6.29.
Affected products
- parse-community parse-server: before 8.6.29; from 9.0.0 before 9.6.0; 9.6.0-alpha1, 9.6.0-alpha2 — fixed in 8.6.29, 9.6.0
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.29, 9.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/releases/tag/8.6.29
- https://github.com/parse-community/parse-server/releases/tag/9.6.0-alpha.3
- https://github.com/parse-community/parse-server/security/advisories/GHSA-q3vj-96h2-gwvg
Get alerted when CVE-2026-31856 or the next vulnerability affects your stack