What’s Vulnerable › Vulnerabilities
CVE-2026-31863: Improper Restriction of Excessive Authentication Attempts in github.com/anyproto/anytype-heart
- Severity: medium (CVSS 4.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-11 · updated 2026-06-17
- Weakness: CWE-307
Description
Anytype Heart is the middleware library for Anytype. The challenge-based authentication for the local gRPC client API can be bypassed, allowing an attacker to gain access without the 4-digit code. This vulnerability is fixed in anytype-heart 0.48.4, anytype-cli 0.1.11, and Anytype Desktop 0.54.5.
Affected products
- Anytype Cli: before 0.1.11 — fixed in 0.1.11
- Anytype Desktop: before 0.54.5 — fixed in 0.54.5
- Anytype Heart: before 0.48.4 — fixed in 0.48.4
How to fix
Upgrade to a fixed version: Anytype Cli 0.1.11; Anytype Desktop 0.54.5; Anytype Heart 0.48.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-31863 or the next vulnerability affects your stack