What’s Vulnerable › Vulnerabilities
CVE-2026-31871: Parse Server has a SQL Injection via dot-notation sub-key name in `Increment` operation on PostgreSQL
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-11 · updated 2026-06-17
- Weakness: CWE-89
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.5 and 8.6.31, a SQL injection vulnerability exists in the PostgreSQL storage adapter when processing Increment operations on nested object fields using dot notation (e.g., stats.counter). The sub-key name is interpolated directly into SQL string literals without escaping. An attacker who can send write requests to the Parse Server REST API can inject arbitrary SQL via a crafted sub-key name containing single quotes, potentially executing commands or reading data from the database, bypassing CLPs and ACLs. Only Postgres deployments are affected. This vulnerability is fixed in 9.6.0-alpha.5 and 8.6.31.
Affected products
- parse-community parse-server: before 8.6.31; from 9.0.0 before 9.6.0; 9.6.0-alpha1, 9.6.0-alpha2, 9.6.0-alpha3, 9.6.0-alpha4 — fixed in 8.6.31, 9.6.0
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.31, 9.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/releases/tag/8.6.31
- https://github.com/parse-community/parse-server/releases/tag/9.6.0-alpha.5
- https://github.com/parse-community/parse-server/security/advisories/GHSA-gqpp-xgvh-9h7h
Get alerted when CVE-2026-31871 or the next vulnerability affects your stack