What’s Vulnerable › Vulnerabilities
CVE-2026-31872: Parse Server has a protected fields bypass via dot-notation in query and sort
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-11 · updated 2026-06-17
- Weakness: CWE-284
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.6 and 8.6.32, the protectedFields class-level permission (CLP) can be bypassed using dot-notation in query WHERE clauses and sort parameters. An attacker can use dot-notation to query or sort by sub-fields of a protected field, enabling a binary oracle attack to enumerate protected field values. This affects both MongoDB and PostgreSQL deployments. This vulnerability is fixed in 9.6.0-alpha.6 and 8.6.32.
Affected products
- parse-community parse-server: before 8.6.32; from 9.0.0 before 9.6.0; 9.6.0-alpha1, 9.6.0-alpha2, 9.6.0-alpha3, 9.6.0-alpha4, 9.6.0-alpha5 — fixed in 8.6.32, 9.6.0
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.32, 9.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/releases/tag/8.6.32
- https://github.com/parse-community/parse-server/releases/tag/9.6.0-alpha.6
- https://github.com/parse-community/parse-server/security/advisories/GHSA-r2m8-pxm9-9c4g
Get alerted when CVE-2026-31872 or the next vulnerability affects your stack