What’s Vulnerable › Vulnerabilities
CVE-2026-31875: Parse Server MFA recovery codes not consumed after use
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-11 · updated 2026-06-17
- Weakness: CWE-672
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.7 and 8.6.33, when multi-factor authentication (MFA) via TOTP is enabled for a user account, Parse Server generates two single-use recovery codes. These codes are intended as a fallback when the user cannot provide a TOTP token. However, recovery codes are not consumed after use, allowing the same recovery code to be used an unlimited number of times. This defeats the single-use design of recovery codes and weakens the security of MFA-protected accounts. An attacker who obtains a single recovery code can repeatedly authenticate as the affected user without the code ever being invalidated. This vulnerability is fixed in 9.6.0-alpha.7 and 8.6.33.
Affected products
- parse-community parse-server: before 8.6.33; from 9.0.0 before 9.6.0; 9.6.0-alpha1, 9.6.0-alpha2, 9.6.0-alpha3, 9.6.0-alpha4, 9.6.0-alpha5, 9.6.0-alpha6 — fixed in 8.6.33, 9.6.0
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.33, 9.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/releases/tag/8.6.33
- https://github.com/parse-community/parse-server/releases/tag/9.6.0-alpha.7
- https://github.com/parse-community/parse-server/security/advisories/GHSA-4hf6-3x24-c9m8
Get alerted when CVE-2026-31875 or the next vulnerability affects your stack