What’s Vulnerable › Vulnerabilities
CVE-2026-31877: Frappe SQL Injection due to improper field sanitization
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-11 · updated 2026-06-17
- Weakness: CWE-89
Description
Frappe is a full-stack web application framework. Prior to 15.84.0 and 14.99.0, a specially crafted request made to a certain endpoint could result in SQL injection, allowing an attacker to extract information they wouldn't otherwise be able to. This vulnerability is fixed in 15.84.0 and 14.99.0.
Affected products
- frappe: before 14.99.0; from 15.0.0 before 15.84.0 — fixed in 14.99.0, 15.84.0
How to fix
Upgrade to a fixed version: frappe 14.99.0, 15.84.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-31877 or the next vulnerability affects your stack