What’s Vulnerable › Vulnerabilities
CVE-2026-31878: Frappe: Possible SSRF by any authenticated user
- Severity: medium (CVSS 5.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-11 · updated 2026-06-17
- Weakness: CWE-918
Description
Frappe is a full-stack web application framework. Prior to 14.100.1, 15.100.0, and 16.6.0, a malicious user could send a crafted request to an endpoint which would lead to the server making an HTTP call to a service of the user's choice. This vulnerability is fixed in 14.100.1, 15.100.0, and 16.6.0.
Affected products
- frappe: before 14.100.1; from 15.0.0 before 15.100.0; from 16.0.0 before 16.6.0 — fixed in 14.100.1, 15.100.0, 16.6.0
How to fix
Upgrade to a fixed version: frappe 14.100.1, 15.100.0, 16.6.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-31878 or the next vulnerability affects your stack